Symptom
Unable to edit user in user maintenance.
Chaging role of user in user maintenance.
Environment
Successfactors
Online Report Designer
Reproducing the Issue
Home->Reporting->Analytics->Admin->User Maintenannce->Select user and Click on Edit ->Change Role and Save.
It throws the below error message:
Cause
This is due to no valid email id present for the existing user.
This happens if user details are uploaded via bulk user upload and email address is not available in the source data sheet.
Resolution
Either reupload the bulk user source data sheet by adding the correct email address
OR
Delete the user and proxy with the same user in the instance and click on analytics tab once again.
Now the user details will get registered with the correct details and now you could modify the user details in User Maintenance.
Keywords
User Maintenance Email Address not valid Modify User in user maintenance , KBA , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, YouCalc, ORD) , Problem