Symptom
When you try to update the registered product in C4C, you get an error message "Enter a Customer".
Environment
- SAP Cloud For Customer Integration with ERP
- SAP Cloud For Customer
Reproducing the Issue
- Go to Installed Base Work center.
- Navigate to Registered Products section.
- Open the object "XYZ" (XYZ is a Registered Product replicated from ERP to C4C).
- Try to do some change and save the object, you get an error "Enter a Customer".
Cause
- From 1711 release of SAP Cloud For Customer, you are allowed to replicate a Registered Product to C4C without associating a Customer to it.
- You are trying to modify a replicated Registered Product (which doesn't have a customer), this is not allowed in C4C
Resolution
If there is a real need to update the Registered Product, you need to replicate those changes from ERP to C4C.
Note : Standard creation of Registered Product in C4C remains same where account association is mandatory.
Keywords
Error "Enter a Customer" while saving the registered product in C4C ; Registered Products in C4C ; , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To
Product
SAP Cloud for Customer add-ins 1802 ; SAP Hybris Cloud for Customer add-ins 1711
SAP Knowledge Base Article - Public