Symptom
- Customer getting error for confirmation iflow during Odata API upsert
Entity : EmployeeDataReplicationConfirmation / SFOData.EmployeeDataReplicationConfirmation - Packaged Integration: EC Payroll (AddOn) to EC - Employee Confirmation
- Boomi Process Log Error
HTTP Code: 200 - OK API Response: ERROR - Save batch with same externalCode failed! User XXXXXX does not exist - API response Error
{"key" : null, "status" : "ERROR", "editStatus" : null, "message" : "Save batch MDF object failed! null", "index" : 0, "httpCode" : 500, "inlineResults" : null...}
Environment
Successfactors
DELL Boomi
Reproducing the Issue
Employees with the following user IDs have been purged from the EC system and that the employees also do not exist in the Payroll system.
Cause
The replication of absences assigned to those employees still continues because there are Data Replication Proxy records assigned to those employees in the EC system.
Those Data Replication Proxy records need to be deleted manually to stop the replication of absences and to avoid confirmation errors.
There are no entries for them in the key mapping table PAOCFEC_EEKEYMAP
Resolution
1. Go to Admin Center > Import and Export Data.
2. Export all Data Replication Proxy records.
In the export file, find the records assigned to the listed user IDs and add the operator "delete" to those lines as described in :
Deleting Records for MDF Objects Through Import
3. Import the file to delete the Data Replication Proxy records.
See Also
2272925 - Data Replication Monitor issues
2167526 - How to delete an entry from Data Replication Monitor in Successfactors system
Keywords
EmployeeDataReplicationConfirmation, SFOData.EmployeeDataReplicationConfirmation Data Replication Proxy, PAOCFEC_EEKEYMAP, Save batch with same externalCode failed, purged User Ids , KBA , LOD-SF-INT-DRM , Data Replication Monitor , LOD-SF-INT , Integrations , LOD-SF-INT-CE , Compound Employee API , Problem