SAP Knowledge Base Article - Public

2582400 - Access Restriction Not Working

Symptom

You have setup access restrictions for objects such as opportunities or appointments, but the restriction is not working.

Environment

SAP Hybris Cloud for Customer 1711/04

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Opportunities view.
  3. Search for and open opportunity ID XXX (XXX represents the ID of an opportunity that your access is restricted).
  4. You are able to see and edit the opportunity.

Cause

You are assigned to the Data Privacy work center.

This is a work center meant to administrators, that have full access to the system. This work center assignment overwrites other restrictions.

Resolution

If the restriction is needed, the work center assignment must be removed.

To do so:

  1. Go to the Administrator work center.
  2. On the General Settings view, click on Business Users.
  3. Search and select business user ID 123 (123 represents the ID of the business user).
  4. Click on Edit > Access Rights.
  5. Go to the Work Center and View Assignments tab.
  6. Uncheck the box for DATAPRIVACY.

Keywords

Access Restriction ; Opportunities ; Sales Orders ; Activities ; Appointments ; Visits , KBA , AP-RC-DP-RAL , Data Privacy: Read Access Logging , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions