Symptom
You added additional address line fields to the header on accounts. You can maintain the field in edit mode, but in read mode the entries are not displayed.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Go to the Customers work center.
- Go to the Accounts view.
- Open any account.
- Observe that on header level, address line 1 and address line 2 are not visible.
- Go to Edit.
Result: Address lines 1 and 2 are displayed and can be maintained.
Cause
Address lines 1 and 2 depend on the other postal address attributes filled for the instance.
Resolution
If you would like to see address lines 1 and 2 in read mode, you can achieve this via edit master layout.
- Go to the Customers work center.
- Go to the Accounts view.
- Open any account.
- Go to Adaptation.
- Go to Edit.
- Go to the address lines one by one.
- Open Change Properties on the far right of the adaptation bar.
- Select from the drop down: Visible in read and edit mode.
- Go to End Layout Changes.
Keywords
address, account address, address fields, edit address lines , KBA , LOD-CRM-ACC , Account , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions