Symptom
How to report on Leave Balance excluding Accrual of Privileged Leave Entitlement for terminated users
Environment
- SuccessFactors HCM Core
- Report Center
- Advanced Repoting
Reproducing the Issue
User is terminated however the Leave Balance is calculated including Accrual Privileged Leave Entitlement after termination date.
- Go to Report Center or Analytics
- Run the Report on Leave Balance
- Result output is more that what expected /
Cause
The user is terminated but he is still eligible to the Privileged Leave. Hence the system is adding all the Accrual after the termination Date
Resolution
- Go to Admin Center >
- Manage Time Off Structures >
- Time Account Type Eligibility Status >
- check if it is set to : Eligible = Yes
- If the Eligibility Status is set Eligible = Yes,
- Contact the Employee Central Team to correct the status.
If the customer want to keep the same status but remove the additional "Accrual" fater the termionation date in the Leave Balance Report, Do the following:
- Go to the Report Center or Analytics
- Select the affected Report "Leave Balance" and Edit
- Select Employment Detail > Add "Last Worked Date" or "Terminated Date"
- Create a Calculated column with the condition below:
If the bookingDate is "Less or Equal" to "Last Worked Date". THEN Value == bookingAmount ELSE Value== 0
See Screenshot below
In the Pivot Query add the Calculated Column created in the Measures.
The output result will exlcude all accrual added after the termination date even though the terminated user is still eligible.
Keywords
-
Leave balance excluding Accrual Privileged Leave Entitlement after termination date
- Incorrect value for Leave Balance in Pivot Query
- Wrong Calculated value in Advanced Reporting Leave Balance Report
- Advanced Reporting