Symptom
While sending an offer letter to a candidate as PDF attachment, a user sees 2 types of attachments in the template.
Reproducing the Issue
When a user is emailing an Offer to candidate they have an option to initially attach a document. Then when they select Send as PDF both the offer letter and original attachment appear in the 'Offer Attachment' section above the template as expected.
However, when another attachment is added before the letter is sent, it only appears below the email template as an attached document.
Hence even though there are 3 Documents attached, 2 appear in the 'Offer Attachment' section and 1 below causing confusion to the user.
Cause
This is an expected behavior by design.
Resolution
This UI behavior is used to differentiate between Offer Attachments and Email Attachments.
1. When a user is emailing an Offer to candidate they have an option to initially attach a document.
> User is adding this attachment on the same screen where he/she can select Offer Letter template. These attachments are deemed to be Offer Attachments.
2. When another attachment is added before the letter is sent, it only appears below the email template as an attached document.
> User is adding this attachment on the screen where he/she can select an email template. These attachments are deemed to be Email Attachments.
This UI behavior is only for Recruiting User. Eventually, a candidate will see all the 3 attachments without any demarcation of Offer or Email attachment.
Keywords
Offer Letter attachment , KBA , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , Problem