Symptom
Deduction records are not displayed/created after requesting an advance
Environment
SuccessFactors Employee Central Advances
Reproducing the Issue
Navigate to my employee file---->Eligibility for advances--->Request an advance which has auto recovery enabled--->Check the deduction portlet--->Deduction records are not created
Cause
This can be because of following reasons:
1.Deduction started date might be in future.Recurring Deduction Item will be displayed on the deduction portlet based on the recurring deduction start date.
For example : If the Recurring Deduction Start Date is June 1st 2018 until that you can't see the record on the deduction portlet.
2."Pending data" is set as "No" in non recurring payment object
Resolution
Deduction started date in future
The Employment information page load the records 'as of today'. So to view the future dated records, please choose the valid date from 'As of date' on top of the Employment information page. Then you will see the records.For example: If deduction start date is 01/06/2018, change the as of date to 01/06/2018.
Pending data value is NO
Pending data value for advances should be set as YES.Else it may lead to some inconsistencies if workflow is enabled.
Admin center---->Configure object definitions----->Search Non recurring payment----->Change the value in Pending data to YES.
Keywords
Recurring deduction, Advances, Deduction,Auto recovery,Workflow , KBA , LOD-SF-EC-ADV , Advances , LOD-SF-EC-DED , Deductions , Problem