SAP Knowledge Base Article - Public

2583162 - Unable to Edit the Product Category From a Product Within an Opportunity

Symptom

Once you add a Product to an Opportunity you are not able to edit the Product Category. The only way to do this is to removing the Product and adding it again.

Environment

SAP HYBRIS CLOUD FOR CUSTOMER

Reproducing the Issue

  1. Go to the Sales work center.
  2. Select the Opportunities view.
  3. Open Opportunity ABC (ABC represents the name of the Opportunity).
  4. Go to the Products facet.
  5. Click to Add a product.
  6. Select the Product and the Product Category.
  7. Save it.
  8. Now click in the Edit button to edit the Opportunity.
  9. The Product Category field will be greyed out.

Cause

Currently the Product Category can only be changed in the Product Master Data and not directly in the Sales Document. This was created to avoid master data inconsistencies.

Resolution

This is the SAP Hybris Cloud for Customer expected behavior. If you wish to change the Product please remove the existing one and add the new Product.

Keywords

Products; C4C; Opportunity; Product Category , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-PRO , Products , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions