Symptom
When importing data to Learning, the system returns a validation error similar to "The *** ID does not exist", where *** can be User, Role, etc.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Navigate to Learning Administration >
- System Administration >
- Import Data >
- Select import and enter the options for the import in question >
- Click Submit >
- Import Job fails >
- Go back to Import Data menu and download the Error Log available >
- When opening it, navigate to the last column "Comment" >
- See the error.
Cause
The Learning entities IDs entered in the files are case sensitive.
Resolution
Please correct the ID in question, making sure to exactly match the same value currently the system (note that it is case sensitive, for example "DEFAULT USER" should be used instead of "Default User").
When entering the User ID, make sure to enter the zeros on the left and to keep it in the excel file. Sometimes the excel itself removes the zeros in the left. For example, the user ID is '00012345' in the system. This should match exactly in the file being imported.
See Also
Keywords
Import, Data, tool, ID, not, exist, case, sensitive, unique, user, role, file, excel, imported, error, comment, download, match, matches, exact, exactly , KBA , LOD-SF-LMS-IMP , Import Data Tool , LOD-SF-LMS , Learning Management System , Problem