Symptom
You have replicated Sales Order from ERP system to C4C, you find that Opportunity ID is not visible in Sales Order but it is available in incoming payload.
Environment
Cloud for Customer
Reproducing the Issue
-
Go to the Sales work center & Sales order view..
- Open the Sales Order & Product section.
- The line item has the field Opportunity ID, which is now empty.
-
Go to the Web Service Message Monitoring.
- Find the relevant message.
- Select the Message & view the payload.
- Under the TextCollection, ContentText Opportunity ID XXXXX is available.
Example Payload Section:
<TextCollection textListCompleteTransmissionIndicator="true">
<Text>
<TypeCode>0001</TypeCode>
<ContentText languageCode="ZH">XXXXX</ContentText>
</Text>
</TextCollection>
Cause
Opportunity ID is coming in TextCollection should be visible in External Note & it is not visible because communication Language is maintained respective activity.
Resolution
- Go to the Business Configuration work center.
- Open the activity Communication Language for Data Replication.
- Maintain the language as per languageCode in available in Payload.
See Also
Please refer the Blog for more information
https://blogs.sap.com/2017/06/12/text-collection-integration-in-cloud-for-customer/
Keywords
Text Collection , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem