SAP Knowledge Base Article - Public

2583769 - Opportunity ID is Available in Payload but not Visible in Sales Order

Symptom

You have replicated Sales Order from ERP system to C4C, you find that Opportunity ID is not visible in Sales Order but it is available in incoming payload.

Environment

Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center & Sales order view..
  2. Open the Sales Order & Product section.
  3. The line item has the field Opportunity ID, which is now empty.
  4. Go to the Web Service Message Monitoring.
  5. Find the relevant message.
  6. Select the Message & view the payload.
  7. Under the TextCollection, ContentText Opportunity ID XXXXX is available.

Example Payload Section:

       <TextCollection textListCompleteTransmissionIndicator="true">
          <Text>
            <TypeCode>0001</TypeCode>
            <ContentText languageCode="ZH">XXXXX</ContentText>
          </Text>
        </TextCollection>

Cause

Opportunity ID is coming in TextCollection should be visible in External Note & it is not visible because communication Language is maintained respective activity.

Resolution

  1. Go to the Business Configuration work center.
  2. Open the activity Communication Language for Data Replication.
  3. Maintain the language as per languageCode in available in Payload.

See Also

Please refer the Blog for more information

https://blogs.sap.com/2017/06/12/text-collection-integration-in-cloud-for-customer/

Keywords

Text Collection , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions