Symptom
When trying to add some Task to an Item via Import Data tool, the importing fails and the error estates "The record already exists.".
Environment
SuccessFactor Learning Management System (LMS)
Reproducing the Issue
You have to already have downloaded the Task Template file for importing and populated it accordingly.
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Go to System Admin->Tools->Import Data;
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Select "Task" for Record Type;
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Leave Action as "Import Data" and Import Option as "Add";
- Browse and select the appropriate file created previously;
- Hit "Submit";
- Select to "" or " according to your business process;
- The importing will fail;
- In the "Import Results" select to "Download" the Error Log and open it;
- The error in the Comment column will be "The record already exists."
Cause
The Task which was supposed to be added to the Item already exists, when selecting to "Add" a Task, the Task must not already be created in the system.
Resolution
When trying to Add a Task to an Item, if the task already was created in the system, for "Import Option" choose "Update" or "Add and Update" accordingly.
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Update: will not create any new task in the system but will update the already existing ones and can add a Task to an Item (provided that the Task already is created in the system);
- Add and Update: behave similarly to Update, however if the task is not created in the system before running the Import Data job, it will create the respective Task in the system.
Keywords
Import Data tool, The record already exists, Error, Add, Update, Add and Update , KBA , LOD-SF-LMS-ADM , System Admin, Global Variables, References , Problem