Symptom
User ABC (ABC represents the user name) is able to see tickets assigned to user XYZ (XYZ represents the user name).
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Logged in with user ABC, go to the Service work center.
- Go to the Tickets view.
- Restrict field Assigned To = user XYZ.
- Some tickets appear.
Cause
If a logged-on user is a part of the involved parties of a ticket in any of the below roles:
- Processor.
- Service Technician.
- Partner contact.
- Reporter.
- Reported For (Employee in Employee Support Ticket).
Those can be seen in the Involved Parties facet of the ticket, the user always has access to the ticket.
Resolution
This is the standard behavior of the system.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:
See Also
2470851 - Unauthorized User is Able to Edit Tickets
2343326 - Access Restrictions And Context For Ticket Work Center Views
2777265 - User Can See Tickets Assigned To Other Users
2765281 - Access Restrictions for Service Technician Not Working
Keywords
ticket, access right, party role , KBA , csg_q , LOD-CRM-SRP , Service Request Processing , How To