SAP Knowledge Base Article - Public

2584838 - The Workflow Rule for Account Activation Does Not Work

Symptom

You create a Workflow Rule to Activate Accounts. Once you have selected the relevant conditions and actions the Account is not activated.

Reproducing the Issue

Assuming that you have Account XYZ (XYZ represents the account name) and the Status is Blocked. You create Workflow Rule ABC (ABC represents the workflow rule name) in order to Activate Accounts like XYZ (Status: Blocked).

  1. Go to the Administrator Workcenter.
  2. Go to the Task Distribution View.
  3. Select the Workflow Rules Sub-view.
  4. Click on New.
  5. On Step 1: Enter Basic Data.
  6. Enter a Description ABC.
  7. Select Business Object: Account.
  8. Select Timing: On Every Save.
  9. Click on Next > Step 2: Define Conditions.
  10. Add a group of conditions according to your need.
  11. Click on Next > Step 3: Define Actions.
  12. Select Rule Type: Action.
  13. Select Trigger Action: Activate.
  14. Review and Confirm.

After meeting the Rule conditions, Account XYZ is not activated.

Cause

When creating such Workflow Rule you have to specify which of the actions should be taken for specifc status.

Resolution

To solve the issue, you have to choose the Action according to your Account status:

  1. Revoke Obsolescensce > For Obsolete status.
  2. Activate > For In Preparation status.
  3. Unblock > for Blocked status.

Note: The point 2 is valid for Accounts with "In Preparation" status only, not for Accounts which have combination status "In Preparation" + MarketingLeadIndicator = true (created by Lead upload), which should not be covered by the Account/Contact workflow object.

Keywords

KBA , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions