Symptom
When a new account is created, the currently logged in user is defaulted as the owner. If you change the owner, you will be automatically added to the Account Team with the role Account Team Member.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
1. Log in to the system with user EMPLOYEE_XYZ (EMPLOYEE_XYZ represents your user name).
2. Go to the Customers work centre.
3. Go to the Accounts view.
4. Click New.
5. Select Owner DEF (DEF represents the new owner’s name).
6. Click on the Save button.
7. Open the Account that you created.
8. Go to the Overview tab.
Result: You (user EMPLOYEE_XYZ) have been automatically added to the Account Team.
Cause
When you create a new account using the quick create (QC) in a system where the territory management is not scoped, the logged in employee is defaulted as the owner.
If you overwrite this owner (EMPLOYEE_XYZ) with another employee (DEF), the new employee(DEF) is added to the account team with party role 142 (Employee Responsible) and the employee (EMPLOYEE_XYZ) initially defaulted is added to the account team with party role 211 (Account Team Member).
This is currently the hardcoded logic in the Account Quick Create and has nothing to do with the party determination.
Resolution
This is the expected system's behaviour.
Keywords
account, account's owner, account team, Employee Responsible, Account Team Member , KBA , account , owner , account team , account team member , employee responsible , LOD-CRM-ACC , Account , How To