Symptom
You replicate leads from SAP CRM to Cloud for Customer (C4C) and you notice that all the replicated leads have status 'Open' in C4C.
Environment
SAP Hybris Cloud for Customer
SAP CRM
Reproducing the Issue
Pre-requisites: you have a working communication scenario using 'Lead Replication from SAP Business Suite' and you replicated a lead from your CRM system to C4C.
-
Go to the Administrator work center.
- Open Web Service Message Monitoring.
- Search for the incoming message for the lead you replicated from CRM. View the payload and observe the status tags: there is no UserStatusCode within the Status tags.
- Go to the Sales work center.
- Go to the Leads view.
- Open lead ABC (ABC represents the ID of the replicated lead).
Observe the status field of the lead: the lead has 'Open' status, however, in your CRM the status is different.
Cause
The configuration for the status of the lead is not setup properly in your middleware and/or in C4C.
Resolution
In order to have the same status for the leads in CRM and C4C, we recommend using the UserStatusCode during replication.
1. You need to enable the mapping for:
/ns0:LeadReplicationBulkReplicateRequest/LeadReplicateRequestMessage/Lead/Status/UserStatusCode
UserStatusCode is delivered as inactive for backward compatibility reasons, therefore, it is not enabled by default.
2. You need to maintain the user status for the lead in Business Configuration work center (Leads activity > Maintain Status).
3. You need to setup and maintain the value mapping (CRM:Status/COD:UserStatusCode) in your middleware.
Keywords
lead status, open status, incorrect status, UserStatusCode , KBA , LOD-CRM-INT-CRM , Integration of C4C with CRM , How To