SAP Knowledge Base Article - Public

2585473 - ##### Belongs to EC Data Thus Can't Be Purged / There is data for this user in Employee Central (EC)

Symptom

  • Cannot purge an Inactive employee
  • When trying to do a full purge of an InActive user via DRM, it fails with the following message in the resulting UserObjectType.csv: ##### belongs to EC Data thus can't be purged

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HCM Suite
  • SAP SuccessFactors Employee Central
  • Data Retention Management

Reproducing the Issue

  • In this scenario the user had two completely different User/Employee IDs (EC)
  • The first had the desired data and was set to Active
  • The second was made InActive and a purge was attempted on this same ID

Cause

This was caused by the fact Both User/Employee IDs were associated to an identical person-id-external (EP). We can confirm that as follow:

    1. Run a Person and Employment Export adhoc report
    2. Select the following columns:
      • person-id-external
      • User/Employee ID
      • lastName
      • firstName
    1. Then filter on the name of the user
    2. The preview would show person-id-external is identical for both records

  

Resolution

The steps to be executed for these requests are:  FOR Employee Central User

  • Terminate the user  following KBA 2511979 - Employee Central: How do I Terminate employees via Import?
  • Download the UDF file and verify that Terminate user has been set to inactive
  • Perform an employee export of the valid User/Employee ID
  • Make sure BOTH User/Employee IDs are made Inactive 
  • Do a full purge of BOTH inactive User/Employee IDs. Important Note: There is a check in the purge tool, "There is data for this user in Employee Central (EC)". Un-check this and run the "Purge Inactive User" again.

Note: the checkbox "There is data for this user in Employee Central (EC)" is an option that is enabled by default to make sure that users with an existing EC data are not selected for purge. That is, this option protects users from purge as long as employee data is stored for them. So, in other words, if the user that you are attempting to purge has already EC related data and you are keeping this checkbox enabled you are forcing the purge to fail.

ec purge.png

See Also

  • 2088065 - Data Retention Management - Purge Data - Platform
  • 3058601 - How To Check Soft or Permanent Purge User
  • 2545988 - How to Purge/Delete users in SuccessFactors Cloud 
  • 2657326 - Data Retention Time Management: Person and Employment Purge Object FAQ
  • 2615360 - Data Protection and Privacy - Data retention time management (DRTM) - Master Data Purge for Inactive Users
  • 2392094 - Re-activate a purged user via employee import feature
  • 2788892 - Unable to Purge User / Employment Because it is a Main Assignment

Keywords

SF, success factors, EC, EP, concurrent, contingent, worker, WF, workforce, work force, global assignment, GA, cannot, in active, DRM, There is data for this user in Employee Central (EC), purge, belongs to EC Data thus can't be purged , KBA , LOD-SF-EC-DRM , Data Retention Management - (DRM & DRTM) EC Data Only , LOD-SF-PLT-DRM , Data Retention Management , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions