Symptom
You want to create a new contact from an incoming call of an unknown number but the fields Phone, Mobile and E-Mail are read-only and can't be edited.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
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Log in to your Cloud for Customer tenant.
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Open the CTI Adapter.
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Select the Simulate button.
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Maintain a phone number, which is not maintained in your Cloud for Customer tenant in the field ANI (Dialing from).
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Select the Simulate button.
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A call from an unknown caller is shown in the Live Activity Pane of your Cloud for Customer tenant.
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Select the New Contact hyperlink.
In the QuickCreate for the new contact, the fields Phone, Mobile and E-Mail are read-only and no information can be maintained.
Cause
This is the expected system behaviour in SAP Hybris Cloud for Customer.
Resolution
The call needs to be assigned to an account, before a new contact can be created.
To do so, please follow these steps:
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When the incoming call is shown in the Live Activity Pane, search for the Account ABC (ABC represents the Account ID) you want to assign this new contact to.
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Hover over Account ABC in the result list.
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Select the check mark that appears on the right hand side, which assigns the call to the Account.
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Select the new contact hyperlink.
The fields are editable and the information can be maintained.
Keywords
CTI incoming call unknown number new contact account assign read only read-only phone mobile E-Mail greyed out grayed out , KBA , LOD-CRM-LA , Live Activity , How To