Symptom
You have flagged an Account with the Sales Support Block flag and now you are not receiving emails from this customer anymore.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisites: An Account XYZ (XYZ stands for an Account) has the Sales Support Block flag set; an email is sent from this Account XYZ to the C4C system while the flag is active on the account.
-
Go to the Activities Work Center.
- Go to the Emails view.
Result: The email has not been received.
Cause
If a Sales Support Block is set for an Account, it applies to all related business objects, including:
- Activities (including emails)
- Leads
- Opportunities
- Sales Quotes
- Sales Orders
- Tickets
If an Account maintains multiple Sales Data records (for example, for multiple Organizational Units), the system selects one Sales Data record when a transaction is created. The selection is non-deterministic, meaning the system may choose any available Sales Data record without a defined or predictable order.
Resolution
This is the expected system behavior. If you wish to receive emails from the Account XYZ then you have to remove the Sales Support Block flag.
See Also
Keywords
Sales Block, Sales Support Block, Emails, Activities, Tickets, Sales Data, Org Units , KBA , LOD-CRM-SC-EML , Email , LOD-CRM-ACC , Account , Product Enhancement
SAP Knowledge Base Article - Public