SAP Knowledge Base Article - Public

2585687 - No Activation of Warranty Assignment of Registered Product via Service Order

Symptom

When you create a Service Order with a SHIP Spare Part with assigned Serial Number, there is no Assigment of Account and Warranty in the related Registered Product.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Create a new Service Order.
  2. Select a Spare Part with the Item Type SHIP.
  3. Process the Service Order until you trigger the Spare Part Delivery.
  4. Enter a Serial Number for created Spare Part that is referenced to Registered Product ABC. (ABC represents the Registered Product ID)
  5. Release the Spare Part Delivery.
  6. When You open the Master Data for Registered Product ABC, you see no Account Assignment and no Warranty Assignment as you would expect.

Cause

The Warranty and Account Assignment of Registered Products are designed to happen only in Over the Counter Sales, 3rd Party and stardard Outbound Deliveries. In a Spare Part delivery the assumption is that the delivered Spare Parts remain property of the selling/service executing company and no assignment takes place. This is the intended system behaviour.

Resolution

You can manually assign the Account and Warranty information in the Registered Product Master Data. You can also create a PDI solution to achieve an automatic assignment.

Keywords

Warranty Assignment Registered Products Service Order Spare Part Delivery Serial Number , KBA , AP-IBA-IPO , Installation Point , AP-SVO-SO , Service Order , Problem

Product

SAP Business ByDesign 1711 ; SAP Business ByDesign 1802