Symptom
You are trying to make changes to your custom solution as it is in the status 'Disabled' in the Solution Explorer, even though you can see it is 'Enabled' and 'In Development' status in the Implementation Manager.
Environment
-
SAP Cloud Applications Studio
Reproducing the Issue
- Open the SAP Cloud Applications Studio (SDK).
-
Open the affected custom solution.
- Select View.
- Select 'Implementation Manager'.
- Note that the status is 'In Development'.
- Note that the Solution Enablement for Business User in Cloud Solution is Enabled.
- Select View.
- Select 'Solution Explorer'.
- Note that the status is 'Disabled'
Cause
There is a restore point created for this tenant where the solution is "In Development".
The restore point is considered a backup tenant and it is created on the same physical system (both tenants have the same System ID), and the solution is in "In Development" status in both of these tenants, then one of the tenant's solution is Disabled by default.
Resolution
Request the deletion of the Restore Point from the Service Control Center work center, under Systems view.
See Also
Keywords
Disabled, Implementation, Manager, SDK, PDI, Edit, Solution , KBA , sdk , status , solution , disabled , implementation manager , edit solution , AP-RC-BDS-SOL , ByDesign Studio Solution Explorer , How To