Symptom
Incoming messages to C4C gets cancelled immediately as they arrive in webservice message monitor
Environment
SAP Hybris Cloud For Customer
Reproducing the Issue
- Go to the Administrator work centre
- Go to the Webservice Message Monitor view
- You may observe the incoming message got cancelled without any error message (sometimes with error BusinessDocument Locked)
Cause
SenderSequenceNumber in the incoming message that got cancelled is same/less than the one from latest successful message.
As an example : Lets consider the service interface CustomerOrderReplicationIn from ERP/CRM/S4H to C4C.
1) First message for a Sales Order XYZ arrived in C4C on 1st January 2018 10.00 UTC with SenderSquenceNumber 2018010110000
2) Second message for the same sales order arrived in C4C on 1st January 2018 at 11.00 UTC - however the SenderSequenceNumber is same as above or less than the above number
3) Then the second message will immediately gets cancelled because a newer/same version of that object is already proccessed.
Resolution
1) The SenderSequenceNumber is generated from the IDOC field SERIAL which is the combination of Creationdate and timestamp.
2) C4C will differentiate the incoming message version for a given object id with their SenderSequenceNumber and will process the one with latest sequence number
3) If there are new messages sent to C4C(or existing incoming messages in the queue to be proccessed) with same/lesser value of Sequence number , those will be immediately discarded/cancelled.
See Also
Keywords
C4C Webservice message monitoring ; Incoming messages gets cancelled ; message gets cancelled immediately ; C4C incoming message; , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , LOD-CRM-INT-CRM , Integration of C4C with CRM , Problem