Symptom
Unexpected Changes Happening While Using Account Territory Upload Template.
Reproducing the Issue
- Go to work center Sales.
- Choose the view Territories.
- Choose Account Territory MappingUpload and download File.
- Save Territory = X with Account = A.
- Check Accounts in Territory for Territory X : Account A will be assigned to Territory X.
- Choose Account Territory Mapping Upload and download File.
- Save Territory = Y with Account = A and Territory = Z with Account = A.
- Check Accounts in Territory for Territory X, Y, Z - Account A will no longer be in Territory X - Account A will be assigned to Territory Y as well as Territory Z .
Cause
Upload of Account Territory mapping always used to replace whatever territory mapping for an account already existed in the system. So if Account A was part of Territory 1, and now you are uploading a new mapping where you want Account A to be part of territory 2 and 3. On uploading this excel, system will delete the mapping of Account A with Territory 1 and create new mappings with territory 2 and 3.
Resolution
This is standard system behavior. We know that some customers did not want this behavior but wanted to upload more/additional mapping of an account without removing the existing/current mappings. For this feature we introduced Delta Upload which will only work with what new is being provided in the excel sheet.
For this purpose the template for this action has an additional column - Action - You want to create a mapping or delete a mapping. Upload Account mapping action/button has these 2 sub actions on UI
- Upload Account Territory Mapping -> (Replace Scenario : Replace the existing associations with information provided in the excel sheet)
- Delta Upload -> (Delta Scenario : Just implement the new data, without touching the existing associations)
You can choose to use any of these 2 options based on your scenario."
Keywords
Account Territory Mapping. , KBA , LOD-CRM-TM , Territory Management , Problem