SAP Knowledge Base Article - Public

2586363 - Account Created Without Country Mandatory Field

Symptom

The users are able to create an account without country, even if the country field is set as mandatory.

Environment

SAP Hybris Cloud for Customer 1711/04

Reproducing the Issue

  1. Go to the Customer work center.
  2. Go to the Account view.
  3. Click on New Account button.NEW.PNG
  4. Fill the mandatory fields.
  5. Delete the Country (if it is filled automatic)  or just don't fulfill the field Country (if set as mandatory).No_Country.PNG
  6. Click on Save.

You will be able to create an account without the mandatory field "Country" to be fulfilled.

 

Cause

The country field is only mandatory if any postal address field (including country) is filled.
If country is the only postal address field filled and the country maintained in the address is cleared, then, the field is not mandatory anymore.

Resolution

This is a standard system behavior. You can set other postal address as mandatory, for example, City or State, then you will not be able to create an account without country field fulfilled.

Keywords

Accounts, Mandatory Fields, Country Mandatory, Without Country. , KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins 1802 ; SAP Cloud for Customer add-ins 1902 ; SAP Cloud for Customer add-ins 1905 ; SAP Hybris Cloud for Customer add-ins 1711