SAP Knowledge Base Article - Public

2586363 - Account Created Without Country Mandatory Field

Symptom

The users are able to create an account without country, even if the country/region field is set as mandatory.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customer work center.
  2. Go to the Account view.
  3. Click on New Account button.
  4. Fill the mandatory fields.
  5. Delete the Country (if it is filled automatic) or just don't fulfill the field Country (if set as mandatory).
  6. Click on Save.

You will be able to create an account without the mandatory field "Country" to be fulfilled.

Cause

The country field is only mandatory if any postal address field (including country/region) is filled.
If country/region is the only postal address field filled and the country maintained in the address is cleared, then, the field is not mandatory anymore.

Resolution

This is a standard system behavior. You can set other postal address as mandatory, for example, City or State, then you will not be able to create an account without country field fulfilled.

If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.

Keywords

Accounts, Mandatory Fields, Country Mandatory, Without Country, Cloud for Customer, Mandatory, Country, Individual Customer, Customer, Region. , KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions