Symptom
Sales data based custom party roles are not determined in follow-up sales documents.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
We will use Account and Opportunity as examples.
Pre-requisites:
You have already created a custom party role and activated it as Involved Party for Opportunities.
- Go to the Customers work centre.
- Select the Accounts view.
- Search and open account ABC (ABC represents the name of the customer).
- Select the Opportunities facet.
- Click the New button and create a new opportunity.
- Select the Involved Parties facet in the newly created Opportunity.
You can see that the custom created party role was not determined.
Cause
The custom created party role was not determined because when you created the party role you flagged the Sales Data checkbox, which means that it is a sales data based custom party role and the sales data needs to be the same in both the account and the sales document.
Resolution
In order to solve the issue you have to adjust the opportunity’s sales data so that it matches the account’s sales data.
Keywords
Custom Party Role, Opportunity, Sales Documents. , KBA , opportunity , involved parties , custom party role , LOD-CRM-OPP , Opportunity Management , LOD-CRM-ACC , Account , Problem