SAP Knowledge Base Article - Public

2586507 - Sales Data Based Custom Party Roles Are Not Determined in Follow up Sales Documents

Symptom

Sales data based custom party roles are not determined in follow-up sales documents.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

We will use Account and Opportunity as examples.

Pre-requisites:

You have already created a custom party role and activated it as Involved Party for Opportunities.

  1. Go to the Customers work centre.
  2. Select the Accounts view.
  3. Search and open account ABC (ABC represents the name of the customer).
  4. Select the Opportunities facet.
  5. Click the New button and create a new opportunity.
  6. Select the Involved Parties facet in the newly created Opportunity.

You can see that the custom created party role was not determined.

Cause

The custom created party role was not determined because when you created the party role you flagged the Sales Data checkbox, which means that it is a sales data based custom party role and the sales data needs to be the same in both the account and the sales document.

Resolution

In order to solve the issue you have to adjust the opportunity’s sales data so that it matches the account’s sales data.

Keywords

Custom Party Role, Opportunity, Sales Documents. , KBA , opportunity , involved parties , custom party role , LOD-CRM-OPP , Opportunity Management , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer add-ins 1802 ; SAP Hybris Cloud for Customer add-ins 1711