Symptom
You reply a post on Facebook via C4C and save it properly, however, the replies are missing on Facebook post.
NOTE:
Despite the aforementioned behavior, if you like the post or any existing comment on C4C, you will be able to see the like on Facebook side.
Environment
SAP Hybris Cloud for Customer 1711 / 04
Reproducing the Issue
- Go to the Services work center.
- Go to the Tickets view.
- Open ticket XXX (XXX represents the ID of the tickets).
- Go to the Overview tab.
- Click on Comment hyperlink.
- Type the text and click on Comment button.
- The comment was saved properly and you are able to see it on C4C.
- Go to the Facebook page.
- Go to the post.
- Notice that the comment made via C4C does not appear.
Cause
This may be occurring because the OAuth URL is not maintained.
Resolution
-
Logon into Facebook page with administration user.
- Go to Settings.
- Go to Apps.
- Click on Developers hyperlink.
- Click on My Apps and then select your affected app.
- Go to Facebook Login.
- Add your system URL under "Valid OAuth redirect URIs".
- Click on Save Changes button.
Keywords
Facebook; OAuth; URL; Comment; Missing; C4C; Ticket; , KBA , LOD-CRM-SC-SM , Social Media , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions