SAP Knowledge Base Article - Public

2587031 - 'Cancel not possible; Payment file already generated; Reverse that first' Error Message While Reversing a Bank-to-Bank Transfer

Symptom

When you try to reverse a bank-to-bank transfer you get the error message: 'Cancel not possible; Payment file already generated; Reverse that first'.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Payment Management work center.
  2. Select the Payment Monitor view.
  3. Select the bank-to-bank transfer which you would like to Cancel / Reverse.
  4. Click Edit.
  5. Click Reverse.
  6. Enter Posting Date and Document Description.
  7. Click OK.
  8. Error message is displayed: Cancel not possible; Payment file already generated; Reverse that first.

Cause

When you create a payment file, system will change the status of the bank-to-bank transfer to In Transfer. You can also manually set the status to In Transfer without creating a payment file. The error message when trying to reverse the payment stays the same. When a payment is In Transfer it cannot be canceled. Its status needs to be changed to Ready for Transfer.

Resolution

  1. Go to the Payment Management work center.
  2. Select the Payment Monitor view.
  3. Select the Outgoing Bank Transfer with status In Transfer.
  4. Click Actions for Bank Transaction button (gear icon) and select Set to Not Transferred.
  5. Status of the payment is now changed to Ready to Transfer.
  6. Click Edit > Reverse.

The payment can now be reversed.

Keywords

bank-to-bank transfer; payment file; reverse; cancel; in transfer; rejected , KBA , bank-to-bank transfer , payment file , reverse , cancel , in transfer , rejected , unable to reverse bank to bank transfer , error in bank to bank transfer , AP-PAY , Payment Processing , How To

Product

SAP Business ByDesign all versions