Symptom
When you try to reverse a bank-to-bank transfer you get the error message: 'Cancel not possible; Payment file already generated; Reverse that first'.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Payment Management work center.
- Select the Payment Monitor view.
- Select the bank-to-bank transfer which you would like to Cancel / Reverse.
- Click Edit.
- Click Reverse.
- Enter Posting Date and Document Description.
- Click OK.
- Error message is displayed: Cancel not possible; Payment file already generated; Reverse that first.
Cause
When you create a payment file, system will change the status of the bank-to-bank transfer to In Transfer. You can also manually set the status to In Transfer without creating a payment file. The error message when trying to reverse the payment stays the same. When a payment is In Transfer it cannot be canceled. Its status needs to be changed to Ready for Transfer.
Resolution
- Go to the Payment Management work center.
- Select the Payment Monitor view.
- Select the Outgoing Bank Transfer with status In Transfer.
- Click Actions for Bank Transaction button (gear icon) and select Set to Not Transferred.
- Status of the payment is now changed to Ready to Transfer.
- Click Edit > Reverse.
The payment can now be reversed.
Keywords
bank-to-bank transfer; payment file; reverse; cancel; in transfer; rejected , KBA , bank-to-bank transfer , payment file , reverse , cancel , in transfer , rejected , unable to reverse bank to bank transfer , error in bank to bank transfer , AP-PAY , Payment Processing , How To