Symptom
You notice that a Live Activity simulated call does not show the caller related tickets in RUI.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Login in the system (RUI).
- Open the Live Activity work center.
- Open the SAP Hybris Cloud for Customer CTI Client Adapter.
- Click in Simulate button.
- In the ANI (Dialing from) field, insert ABC (where ABC is the phone number of Account/contact maintained in the system that has related tickets to it.
- Click in Simulate button.
In the Call Information pane you do not see any tickets related to the caller. In HTML5, however, you see them.
Cause
In RUI the ticket search is a text search for the phone number that is calling you across all tickets in the system.
If you insert the caller phone in the search field above, the system will display the tickets related to it. This is aimed at an ongoing improvement to support a wider range of business objects in the search, not only tickets.
Resolution
This is the current system standard behavior. Please note that for this to work properly, you should:
- Go to the Administrator work center.
- Open Service and Social view.
- Select Provided drop-down menu field as SAP CTI Adapter.
- Enable the flag "Search All Fields".
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
CTI Adapter, Related Tickets, RUI, FIORI , KBA , LOD-CRM-LA , Live Activity , LOD-CRM-SRP , Service Request Processing , How To