SAP Knowledge Base Article - Public

2587929 - Not Possible to Delete Item Lines in a Ticket

Symptom

Error message "The item can't be deleted due to the status of the document." when deleting item lines in a Ticket.

Environment

SAP Hybris Cloud for Customer.

Reproducing the Issue

  1. Go to Service work center.
  2. Go to Ticket view.
  3. Open the Ticket 123 (123 represents for the Ticket ID).
  4. Go to SERVICE AND REPAIR facet.
  5. Find ITEMS list.
  6. Select the item line you want to delete.
  7. Click Delete icon under Action column.
  8. Error message “The item can’t be deleted due to the status of the document.” occurs.

Cause

If the Item Work Progress is Started, In process or Finished; or its ERP status is Released, then deletion is not allowed.

This is the standard behavior.

Resolution

Revert the Work Progress status back to Ready.

If the work hasn’t started:

  1. Select the item line.
  2. Click Action wheel on the top right of the ITEMS list.
  3. Choose Undo Work Progress and bring it back to Ready status.
  4. Click the Delete icon.

Once the work has started:

  1. Select the item line.
  2. Change the actual quantity to 0. This is because once there is an actual quantity maintained, the system assumes that work has already started.
  3. You should see the work progress of item changes to Ready.
  4. Click Save.
  5. Click the Delete icon.

This should delete the item line.

Keywords

delete item line; ticket , KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions