Symptom
Error message "The item can't be deleted due to the status of the document." when deleting item lines in a Ticket.
Environment
SAP Hybris Cloud for Customer.
Reproducing the Issue
- Go to Service work center.
- Go to Ticket view.
- Open the Ticket 123 (123 represents for the Ticket ID).
- Go to SERVICE AND REPAIR facet.
- Find ITEMS list.
- Select the item line you want to delete.
- Click Delete icon under Action column.
- Error message “The item can’t be deleted due to the status of the document.” occurs.
Cause
If the Item Work Progress is Started, In process or Finished; or its ERP status is Released, then deletion is not allowed.
This is the standard behavior.
Resolution
Revert the Work Progress status back to Ready.
If the work hasn’t started:
- Select the item line.
- Click Action wheel on the top right of the ITEMS list.
- Choose Undo Work Progress and bring it back to Ready status.
- Click the Delete icon.
Once the work has started:
- Select the item line.
- Change the actual quantity to 0. This is because once there is an actual quantity maintained, the system assumes that work has already started.
- You should see the work progress of item changes to Ready.
- Click Save.
- Click the Delete icon.
This should delete the item line.
Keywords
delete item line; ticket , KBA , LOD-CRM-SRP , Service Request Processing , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions