Symptom
The connector job is stuck in the "INIT - Started" status and an error seen in the connector logs for a particular user:
com.sap.db.jdbc.exceptions.SQLTransactionRollbackExceptionSapDB: [131]: transaction rolled back by lock wait timeout: TrexUpdate failed on table 'YOUR_LEARNING_SCHEMA:PA_STUDENT' with error: transaction rolled back by lock wait timeout: Lock-wait time out exceeded
Environment
SAP SuccessFactors Learning
Reproducing the Issue
Run the connector and see that its "Status" is stuck in "INIT - Started" for hours, noting the above "Symptom" error in the logs.
Cause
Jobs or individual user transactions were stuck in connector node due to database issue.
Resolution
Open a case with details of the connector runtime & affected user records to have the Database Operations team to address it.
See Also
COSD-22156 & INC1578779
Keywords
sap, sf, lms, user, connector, stuck, INIT - Started, status, init, started, error, fail, view, log, logs, transaction, rolled, back, lock, wait, timeout , KBA , LOD-SF-LMS-CON , Connectors , LOD-SF-LMS , Learning Management System , Problem