SAP Knowledge Base Article - Public

2588283 - In The RUI The Product Section is Not Visible on Sales Order Creation

Symptom

When creating a Sales Order in the Responsive UI, the Products section is not visible but it is in HTML5.

Environment

SAP hybris Cloud for Customer

Reproducing the Issue

  1. Log into the system with Responsive UI.
  2. Go to the Sales work center.
  3. Go to the Sales Orders view.
  4. Select the Plus icon to create a new Sales Order.
  5. The Products section is not visible on the creation screen.

Cause

This is the expected system behaviour. Our developers also confirm that they do not plan to change this system behaviour in any upcoming release. The Products can be added to the Sales Order via Add Product button. The Add Products screen has a lot more in terms of available functionality and extensibility and by asking you to move to the next screen, you now have the same view into the product list but with the added advantage of modifying the item proposal using the host of options available.

Resolution

In order to add Products to the Sales Order in the RUI please follow the below mentioned steps:

  1. Log into the Responsibe UI system.
  2. Go to the Sales work center.
  3. Go to the Sales Orders view.
  4. Select the Plus icon to create a new Sales Order.
  5. Select the Add Product button.
  6. Here you can Add or Remove any Products.
  7. Select the Ok button.
  8. The Product has now been added to the Sales Quote.

Keywords

Sales, Orders, Add Product, Responsibe UI, , KBA , sales , orders , add product , responsive ui, , LOD-LE-CQP-CO , Lean Sales Orders , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions