Symptom
You get the error message "The SAP Cloud for Customer Add-In for Microsoft Outlook has not been set up" when logging into Outlook Client-Side Add-In.
Environment
SAP Cloud for Customer
SAP Business ByDesign
Reproducing the Issue
Log into Microsoft Outlook SAP Cloud for Customer add-in, a pop-up is shown as below:
Cause
There are two possible causes for this issue:
- The relevant scoping has not been added in Business Configuration.
- There is Junk value in the Proxy settings.
Resolution
Solution for cause 1:
This message can appear when the scoping elements/questions relevant for the Office Integration were not maintained.
Please follow the steps below to configure the scope correctly:
- Go to the Business Configuration work center.
- Access the Implementation Projects view.
- Select the project and click Edit Project Scope.
- Navigate to step 3, Scoping.
- Expand Communication and Information Exchange
- Ensure that the Office and Desktop Integration checkbox is marked.
- Move on to step 4, Questions.
- Expand Communication and Information Exchange, then Office and Desktop Integration.
- Select the option Integration with Local E-Mail Applications.
- Ensure that question "You can synchronize data between your SAP cloud solution and your users' local e-mail application" is marked.
- Move on to step 5, Review.
- Ensure that the options have been reviewed and click Finish.
Solution for cause 2:
This message can sometimes appear when junk data has populated the fields in Proxy Settings.
Please use the following steps below to remove the junk data:
- Go to Settings in Outlook Add-In.
- Go to Proxy settings.
- Check if any junk value is maintained in Proxy URL.
- Remove junk value and click Apply changes.
For additional details on the setup for Business ByDesign, please refer to the blog post linked in the See Also section below.
See Also
Keywords
Outlook, Error, Outlook Add-In, Scope, Business Configuration, Local E-mail Applications , KBA , LOD-CRM-GW-OUT , Outlook , Problem