Symptom
You see an error message in the web service message monitor stating 'E-mail address is invalid' from the service interface EmailServiceRequestingIn.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
-
Go to the Administrator work center.
- Go to the Web Service Message Monitor on the General Settings view.
- Change the filter to Erroneous.
- Observe the failed transaction with the Service Interface: EmailServiceRequestingIn.
Cause
The mail sent from the customer's mail client has not been setup properly.
The TO field contains a: , (comma) after the recipient address and no other mailing address. Entering a comma after the TO address means the system interprets a second mail ID. The system tries to create another MessageToParty node which cannot be addressed to any receiver as there is no mailing address specified.
You can check the sent XML payload by:
- Highlighting the erroneous message in the web service message monitor.
- Click the View button.
- Choose Payload.
Resolution
Please review your email structure and remove the: , (comma) after a mailing address if there is no address specified.
Keywords
Email, E-mail, mail, address, erroneous, web service message monitor, service interface, comma , KBA , e-mail , email , erroneous , web service message monitor , invalid , address , administrator , LOD-CRM-SC-EML , Email , Problem