Symptom
When changing the Requested On date in a Service Order or a Sales Order, the system does not save the changes but reverts back to the original date.
Environment
SAP Business ByDesign
Reproducing the Issue
We will use a service order as an example.
- Go to the Service Orders Work Centre.
- Go to the Service Order Processing View.
- Show All Orders and enter XXX in the Find Field. (XXX represents the ID of the Service Order).
- Navigate to the General Tab.
- Change the Requested On date to another date in the future.
- Click Save.
- The system automatically reverts back to the original date.
Cause
-
When creating a new Service Order, you can change the Requested Date and it automatically changes the Requested End Date.
- If the Requested End Date was changed manually, the automatic determination stops working.
- If the Service Order was created via a Web Service (A2X), the automatic determination of the Requested End Date is not working.
- Once the Requested End Date determination is disabled, the Requested Date cannot be set to a later date than the Requested End Date.
- In this case the Save fails and the Requested Date is set to the original value.
Resolution
-
Go to the Service Orders Work Centre.
- Go to the Service Order Processing View.
- Show All Orders and enter XXX in the Find Field. (XXX represents the ID of the Service Order).
- Click on View All.
- Navigate to the General Tab. And navigate to Main information Tab.
- When changing the Requested On date to a date in the future, also manually adjust the Requested End date to a date after the Requested On date. The changes can then be saved.
Keywords
Service Order, Requested Date, Requested End Date, Wunschtermin, Gefordertes Enddatum, Serviceauftrag , KBA , change , service order , requested on date , AP-SVO-SO , Service Order , Problem
Product
SAP Business ByDesign all versions