SAP Knowledge Base Article - Public

2588898 - Screen Fails to Load After Changing 'Position' or 'Legal Entity' Fields When Changing Job Information

Symptom

After changing either the 'Position' or 'Legal Entity' fields while performing a change in Job Information for a user, the screen fails to complete the change and continually loads

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

Environment

  • Employee Central - Job Information
  • Employee Central - Position Management
  • Employee Central - Position to job Information Sync

Reproducing the Issue

  1. Navigate to a user's Employee Profile > Scroll down to 'Job Information'
  2. Click on the 'Edit' button > Make a change to either the 'Position' or 'Legal Entity' field
  3. Note that the screen begins to flicker and will not complete the change
    Legal_en_change.jpg

Cause

This issue occurs due to a combination of the 'Legal Entity' field being included in the Position to job Information Sync Rule and in Position Management Settings, in the 'UI Customising' tab, 'Use Company Filter for Position in MSS Job Information and History' being set to 'Yes'

Pos2Job_Legal_Entity.png


UI_Customising.png

Resolution

In order to resolve the loading issue you will need to either;

A) Under 'UI Customising' in 'Positioning Management Settings', Set 'Use Company Filter for Positions in MSS Job Information and History' to 'No'

or

B) Remove 'Legal Entity' from the 'Position to Job Information Sync' Rule
    To do this;
    1. Navigate to Admin Centre > Manage Business Configuration
    2. Click on the 'jobinfo' HRIS Element
    3. Scroll to the 'Position' field > Click on 'Details' 
    4. Scroll down to the 'Trigger Rules' section > Select the 'Position to Job Information Sync' Rule
        Trigger_rules.png
    5. Click on Take Action > Make Correction
    6. Click on the dropdown on 'Legal Entity' > Delete 
        Delete_Legal_Entity.png
    7. Save

Please Note:

  • This rule should NEVER be Always True.
  • The rule should only be triggered if a position is assigned to the job info, this is done through the IF- Condition of the rule, which must check if the:
    Job Information. Position is not equal to Null. 

See Also

For more information on how Position to job Information Sync is affected by Position Management Settings, please see KBA 2386613.

Keywords

Job Information, Legal Entity, Position, Edit Job Information, Screen Loading, Position to job Information Sync, Position Management Settings , KBA , LOD-SF-EC-JOB , Job Information , LOD-SF-EC-POS , Position Management , LOD-SF-EC-EMP , Employment Information (Employment Details) , Problem

Product

SAP SuccessFactors Employee Central 1611 ; SAP SuccessFactors Employee Central 1702 ; SAP SuccessFactors Employee Central 1705 ; SAP SuccessFactors Employee Central 1708 ; SAP SuccessFactors Employee Central 1711 ; SAP SuccessFactors Employee Central 1802