SAP Knowledge Base Article - Public

2589085 - Migrated Opportunity with a Party Role Partner Contact Does Not Show the Name, Email and Phone of the Partner Contact

Symptom

Upon migrating an Opportunity with a Party Role Partner Contact added inside the Involved Parties sheet, it adds a record with role Partner Contact in the Sales Team tab of the Opportunity, but it does not show the Name, Email and Phone of the Partner Contact.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

To migrate Opportunities:

  1. Go to Business Configuration work center.
  2. Select Implementation Projects view or Overview.
  3. Search and Open the activity Migration of Opportunities.
  4. Select Migrate opportunities using the migration tool.
  5. Upload the Migration File.
  6. Execute Migration for the respective Migration File with Migration Mode Add new records.
  7. Migration is successful .

To check the migrated Opportunity:

  1. Go to Sales work center
  2. Go to Opportunities
  3. Show All Opportunities
  4. Search for the Opportunity which you migrated
  5. Open the Opportunity and go to the Sales Team tab
  6. There is a line item available for the Role Partner Contact but the Name, Email, Phone are not available for this Partner Contact, even if the same details is maintained in the Partner Contacts view in Partners workcenter 

Cause

The reason for the reported issue is that there is no Business Partner with ID XXXXX. (XXXXX represents Partner ID.)

Resolution

If it is an External ID, then the value mapping in Migration Workbench is incorrect.
You must use the Business Partner ID.

Keywords

Partner Contact, Migration of Opportunities, Business Partner ID, Involved Parties , KBA , partner contact , migration of opportunities , business partner id , involved parties , LOD-CRM-OPP-EXT , External Opportunity , LOD-CRM-OPP , Opportunity Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions