Symptom
-
Users are launching courses in LMS and the following error message is thrown:
iContent Configuration Exception - Source Module : LAUNCH_PROXY
com.plateau.icontent.entitlement.launchproxy.EntitlementConfigurationException: No account key information was found - please update account configuration...
at com.plateau.icontent.entitlement.launchproxy.helper.IContentLaunchProxyAccountConfig.getAccountPrivateKey(IContentLaunchProxyAccountConfig.java:210)
at com.plateau.icontent.entitlement.launchproxy.servlet.helper.LaunchRequestProcessor.processRequest(LaunchRequestProcessor.java:166)
at com.plateau.icontent.entitlement.launchproxy.struts.LaunchRequestAction.run(LaunchRequestAction.java:91)
at com.plateausystems.elms.client.struts.StatefulBaseActionDelegate.invoke(StatefulBaseActionDelegate.java:520)
Environment
SAP SuccessFactors Learning Management System (LMS)
Cause
There are inconsistencies in the backend configuration.
Resolution
The fix requires internal Operational teams to analyze and fix the error. Please raise an case with the LMS Support team.
Keywords
icontent error lms learning content launch_proxy fail failure exception update account configuration success factors , KBA , LOD-SF-LMS-CNT , Content , LOD-SF-LMS-PCM , iContent , Problem