Symptom
You have maintained a calendar to the service technicians on the employee profile, but the same is not reflected on the resource scheduler when assigning demands.
Environment
SAP Hybris Cloud for Customer 1711/04
Reproducing the Issue
-
Go to the Resource Scheduler work center.
- Go to the Resource Scheduler view.
- Add a demand to the Employee XYZ (XYZ represents the employee ID) on a holiday, for example, 25/12.
- The system allows you to do so even though it is not a working day.
Cause
The Resource Scheduler feature does not consider the calendar maintained for employees as of the current system release.
Resolution
This is the expected system behavior.
You can find more details about the services offered by Cloud Service Center on https://www.sap.com/services/application-development.html . You can contact Cloud Service Center as follows:
a) If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
b) If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of https://www.sap.com/services/application-development.html, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page
An alternative option may be to check the SAP Customer Influencer Site to submit an idea: https://influence.sap.com/SAPCloudforCustomer
A workaround to this is the maintenance of an appointment with the flag All Day Event checked for the holidays. This will make the employee unavailable on those days.
Keywords
Resource Scheduler ; Holidays ; Service Technician ; Calendar , KBA , LOD-CRM-RES , Resource Scheduling , How To