Symptom
You have maintained a calendar to the service technicians on the employee profile, but the same is not reflected on the resource scheduler when assigning demands.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Resource Scheduler work center.
- Go to the Resource Scheduler view.
- Add a demand to an Employee on a holiday, for example, 25/12.
- The system allows you to do so even though it is not a working day.
Cause
The Resource Scheduler feature does not consider the calendar maintained for employees as of the current system release.
Resolution
This is the expected system behavior.
If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.
A workaround to this is the maintenance of an appointment with the flag All Day Event checked for the holidays. This will make the employee unavailable on those days.
Keywords
Resource Scheduler ; Holidays ; Service Technician ; Calendar , KBA , LOD-CRM-RES , Resource Scheduling , How To
SAP Knowledge Base Article - Public