Symptom
When you add a contact from a visit, its e-mail address is missing though it has been maintained in the contact.
Environment
SAP Cloud For Customer
Reproducing the Issue
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Go to the Visits work center.
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Go to the Visits view.
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Open Visit ABC(where ABC is the visit ID)
- Note that the visit is created for the account DEF(where DEF is the account ID)
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Go to the Contacts facet.
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Add the contact XYZ(where XYZ is the contact ID which has email address maintained).
Contact has been added to the visit but there is no e-mail address in the table.
Cause
The contact address determination in C4C is done the following way:
1. If the system finds relation between contact and account of visit, it copies the business address of the contact into the visit.
2. If the system does not find relation between contact and account of visit, it copies the personal address of the contact of visit.
There is no relation between the account DEF and the contact XYZ, hence the contact's personal address has been determined which is blank.
Resolution
You may either associated the contact XYZ to the account DEF or maintain the personal address of the contact XYZ.
Solution A: To associate contact XYZ to the account DEF, please follow the below steps:
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Go to the Customers work center.
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Go to the Accounts view.
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Open account DEF.
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Go to the Contacts facet.
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Add the contact XYZ here along with it's e-mail address and Save.
Solution B: To maintain the personal address of the contact XYZ, please follow the below steps:
- Go to the Customers work center.
- Go to the Contact view.
- Open the contact DEF.
- Go to the Addresses facet.
- Maintain the address here and Save.
Keywords
Business Partner, Account Communication Information , KBA , LOD-CRM-ACT-VST , Visit Planning , LOD-CRM-CON , Contact , Problem