Symptom
-
You are unable to see the e-mail address in the business user overview for a service agent (assigned with a business user) and the edit e-mail
option is grayed out in the Home work center. -
You are unable to see the e-mail address in the business partner data overview for a service agent.
Environment
SAP Business ByDesign
Reproducing the Issue
Case 1: Email address missing in Business User Overview for a service agent.
1. Go to the Application and User Management work center
2. Go to the User and Access Management - Business Users view.
3. Search for user ABC (ABC represents the Service Agents ID).
4. In the Overview screen of user ABC, the e-mail address is missing.
Case 2: E-Mail address missing in Busines Partner Data Overview for a service agent.
1. Go to the Business Partner Data work center.
2. Go to the Business Partner view.
3. Search for Business Partner ABC.
4. In the Overview screen of Business Partner ABC, the e-mail address is missing.
Cause
Case 1: The e-mail address of the Service Agent is not maintained in the field In-House Address of the Service Agent.
Case 2: The e-mail address of the Business Partner is not maintained in the field personal address of the Service Agent.
Resolution
Case 1:
1. Go to the Business Partner Data work center.
2. Go to the Service Agents view.
3. Search for ABC (ABC represents the Service Agents ID)
4. Click on Edit - General.
5. Under field the In-House Address click on the Copy Address hyperlink.
7. Select the Business Residence for the service agent from the list.
8. Click ok.
9. Now the E-Mail field is enabled: Maintain the service agent's e-mail address here. This e-mail address would be reflected in the Business User Overview.
Case 2:
1. Go to the Business Partner Data work center.
2. Go to the Service Agents view.
3. Search for ABC.
4. Click on Edit -> Address.
5. Click on Add Row.
6. Add Main Personal Address.
7. Click ok.
8. Now the E-Mail field is enabled, maintain the service agents e-mail address here and this email address would be reflected in the Business Partner Overview.
Keywords
cannot see, not available, email , KBA , SRD-CC-IAM , Identity & Access Management , Problem