Symptom
-
You are unable to see the e-mail address in the business user overview for a service agent (assigned with a business user) and the edit e-mail
option is grayed out in the Home work center. -
You are unable to see the e-mail address in the business partner data overview for a service agent.
Environment
SAP Business ByDesign
Reproducing the Issue
Case 1: Email address missing in Business User Overview for a service agent.
- Go to the Application and User Management work center
- Go to the User and Access Management - Business Users view.
- Search for user ABC (ABC represents the Service Agents ID).
- In the Overview screen of user ABC, the e-mail address is missing.
Case 2: E-Mail address missing in Busines Partner Data Overview for a service agent.
- Go to the Business Partner Data work center.
- Go to the Business Partner view.
- Search for Business Partner ABC.
- In the Overview screen of Business Partner ABC, the e-mail address is missing.
Cause
Case 1: The e-mail address of the Service Agent is not maintained in the field In-House Address of the Service Agent.
Case 2: The e-mail address of the Business Partner is not maintained in the field personal address of the Service Agent.
Resolution
Case 1:
- Go to the Business Partner Data work center.
- Go to the Service Agents view.
- Search for ABC (ABC represents the Service Agents ID)
- Click on Edit - General.
- Under field the In-House Address click on the Copy Address hyperlink.
- Select the Business Residence for the service agent from the list.
- Click ok.
- Now the E-Mail field is enabled: Maintain the service agent's e-mail address here. This e-mail address would be reflected in the Business User Overview.
Case 2:
- Go to the Business Partner Data work center.
- Go to the Service Agents view.
- Search for ABC.
- Click on Edit -> Address.
- Click on Add Row.
- Add Main Personal Address.
- Click ok.
- Now the E-Mail field is enabled, maintain the service agents e-mail address here and this email address would be reflected in the Business Partner Overview.
Keywords
cannot see, not available, email, Business User Overview, Business Partner Data , KBA , SRD-CC-IAM , Identity & Access Management , Problem
Product
SAP Business ByDesign all versions