SAP Knowledge Base Article - Public

2590777 - Agent's Country is Not Assigned in Ticket Data Source

Symptom

You are using Ticket data source and you have seen that the Country characteristic under Agent is showing as Not Assigned, however, you are able to see the Country assigned to the Agent in the Ticket.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

1. Go to Business Analytics work center and Design Data Sources View;
2. Show All and Find Ticket (CRMSRQHB) data source;
3. Move Agent and Country (under Agent) from Not Currently Shown to Rows;
4. See that the Agent is correctly assigned to the Ticket, but the Country is showing as Not Assigned.
5. Open the respective ticket
6. Go to Involved Parties tab
7. Open XYZ Processor
8. See that the Country is assigned

Cause

This is happening regarding to the field Agent which is coming from the master data source named Party Master Data (CODPARTY). This data source retrieves the data from Business Partner work center and, if you check there, you will see that the mentioned Agent is not assigned to a country.

Resolution

The system is working as expected

Keywords

KBA , AP-RC-ANA-DT-MDA , C4C, ByD, Travel: Datasource / MDAV Design time , How To

Product

SAP Cloud for Customer add-ins 1802 ; SAP Hybris Cloud for Customer add-ins 1705 ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711