Symptom
You are trying to maintain a contact's business communication information (E-mail, Fax, Phone etc.), but you observed these fields are uneditable.
Environment
SAP Business ByDesign
Reproducing the Issue
-
Go to Account Management work center.
- Access the Customers work center view.
- Select the relevant account.
- Click Edit, then select Contacts.
- Notice that the Business Communication fields are read-only and can't be edited.
Cause
Business communication fields for Contacts are dependent on the account–contact relatioship address information, which is shown as Business Address for the contacts. If the corresponding account itself does not have an address maintained, then the contact's business address would be empty — hence, this communication information cannot be maintained.
Resolution
Maintain address information for the account, to do so,
-
Go to the Account Management work center.
- Access the Accounts work center.
- Find and open the relevant account.
- Navigate to the Communication tab, then the Addresses sub-tab.
- Click Add Row.
- Maintain the necessary address information.
- Click Save (or Save and Close).
Now open the corresponding contact record and ensure the Business Address is reflected properly. If not, then manually assign the Business Address from the Account.
- Go to the Account Management work center.
- Navigate to the Contacts work center view.
- Find and select the relevant contact.
- Click Edit, then select Addresses.
- Check if the contact has a row of address type Business Address with the information from the relevant account.
If this is now correct, it should be possible to edit Business Communication data for this contact in the account's screen.
Keywords
Contact, E-Mail, Address, Business Communication, Read-only, Can't Edit , KBA , contact address, contact business addres , AP-BP-BP , BusinessByDesign: Business Partner , How To