Symptom
OData Extension cannot be activated from SDK or UI.
The error raised can be related to the solution being locked to the user currently attempting to activate.
Removing the locks through session administrator in the SDK or XREP is not effective.
Environment
Cloud Applications Studio.
Reproducing the Issue
From the SDK attempt to activate the OData Extension.
This issue can also be reproduced from the OData Editor in the UI of the system.
Select Activate after selecting the parameters of the OData extension
Cause
This issue can be caused by a Language mismatch.
The only supported language in the SDK is English. When logging into the UI in a language other than English, accessing the OData editor results in this OData Extension being flagged in that language. When attempting to activate this, XREP remains in 'staging' and will not activate due to this mismatch.
Hence during Assembly and download for a particular solution, the XREP content for XODATA component is continually in the staging process due to the language mismatch
Resolution
To resolve this the XODATA (OData Extension) needs to be deleted. It can be created once again by logging into the UI or backend of required in English. This will set the XODATA content XREP file language as EN.
It should be noted from 1802 on the default language will be set to English and these kind of issues should not arise.
Keywords
XODATA, OData Extension, Activation, Locked , KBA , AP-RC-BDS-OPS , PDI Operations , Problem
SAP Knowledge Base Article - Public