Symptom
You create a Business Role where the appointment view has not been assigned for the Activities work center. The user can view appointments under different business objects.
Reproducing the Issue
- Go to the Customers work center.
- Go to the Accounts view.
- Open any account.
- Go to the Activities facet.
- You can see the Appointment table.
Cause
This is the expected system behaviour.
If you create a business role where the appointments view is not assigned, the user will not have access to the dementioned sired view within the Activities work center.
The appointment table is still available for other business objects such as Accounts, Opportunities etc.
Resolution
You can create and assign a page layout for the business role and hide the appointment table for different business objects.
Keywords
Business Role, Business User, Activities, Appointment, Access Restriction , KBA , appointment , activities , business role , acces retsriction , LOD-CRM-ACT , Activities , How To