Symptom
You are saving an Opportunity with some empty value Field, you noticed that even though the fields are empty you are still able to save the Opportunity.
For example, you leave any of the following fields empty: Products, Competitors, Contacts, Involved Parties, Related Opportunities, Sales Team.
Environment
SAP Cloud For Customer
Reproducing the Issue
- Go to the Sales work center.
- Go to the Opportunities view.
- Open Opportunity ABC (ABC represents the Opportunity ID).
- Go to the Facet Contact, click the button Add.
- Add new Contact with empty Field values.
- Save the Opportunity.
- Check the Consistency.
You do not observe any error message or inconsistency.
Cause
Currently the system will not generate an error/warning message for empty/blank rows created for the records created in the facet mentioned.
Resolution
There are two possible ways to make certain fields mandatory:
You can maintain certain fields as mandatory via adaptation mode:
- Go to Sales work centre.
- Open Opportunities view.
- Go to Contacts.
- Click on Adapt.
- Edit Master Layout.
- Click on Add.
- Choose the field you want to set as mandatory.
- Click on Change properties.
- Mark the checkbox Mandatory.
- Click on Add.
Now you should not be able to save the Opportunity, without filling this field.
As a second option, this could be also specified via Custom Solution (Partner Developed Infrastructure - PDI).
Keywords
Sales Opportunity, Mandatory, Sales, Field, Adapt, Adaptation Mode, Blank Row , KBA , LOD-CRM-OPP , Opportunity Management , How To