SAP Knowledge Base Article - Public

2592206 - Extension Field Content Deleted in Sales Order After Adjusting Account Address Details

Symptom

In a new Sales Order you maintain an Account. You then enter data into an extension field.
Later you change the address details of the account via the Address Details link.

The data just entered in the extension field gets deleted.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Choose New Sales Order from the Common Task list.
  3. Navigate to the General tab.
  4. Enter an account XYZ (XYZrepresents the ID of the Account).
  5. Enter data in the extension field.
  6. Use the Address Details link and adjust the address of the account.
  7. Click OK.
  8. The system deletes the previously entered value in the extension field.

Cause

The system behaviour is caused by the extension scenario configured for the extension field. For this extension field, the extension scenario Account - General Information to Sales - General Information is activated. The extension field is added in the Sales Order General data. However, it is not added in the Account master data. So, whenever the Account name or address is changed in the General tab of the Sales Order, the value of the extension field is being copied from the General tab of the Account master data to the General tab of the Sales Order. As the extension field does not exist in the General tab of the Account master data, the value of the extension field is reset to blank.

Resolution

There are two options to resolve this system behaviour:

  1. Enter Adaptation mode.
  2. Go to the Sales Orders work centre.
  3. Choose New Sales Order from the Common task list.
  4. Click on Adapt and Edit Screen.
  5. Select Account and click on Extension fields.
  6. Select the extension field and use the Further Usages link.
  7. Navigate to the Extension Scenarios tab.
  8. You will see that the scenario Account - General Information to Sales - General Information is activated.
  9. If you wish, you can deactivate this extension scenario.

Or:

  1. Enter the Adaptation mode.
  2. Go to the Account Management work centre.
  3. Go to the Accounts view.
  4. Click on Adapt and Edit Screen.
  5. In the General tab, select Account.
  6. Add the extension field and enter a relevant value.
  7.  Save the changes.

Keywords

extension field, extension scenario, Sales Order header data, account master data , KBA , extension field , sales order , account master data , extension scenario , BC-DWB-REP-EXT , Extensibility , Problem

Product

SAP Business ByDesign 1711