Symptom
After executing a web service you receive a XML response with the error message "RABAX occured on server side". When you check Web Service Message Monitoring work center view you find the error message An exception was raised in relation to the web service you have performed.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
-
You execute desired web service, for example, via SOAP UI.
- You receive an erroneous XML response similar to the one shown below.
- When you open Administrator work center and go to Web Service Message Monitoring, you find an erroneous web service with the error message An exception was raised.
Example erroneous XML response:
<env:Envelope xmlns:env = "http://www.w3.org/2003/05/soap-envelope">
<env:Header/>
<env:Body>
<env:Fault>
<env:Code>
<env:Value>env:Receiver</env:Value>
</env:Code>
<env:Reason>
<env:Text xml:lang = "en">RABAX occurred on server side</env:Text>
</env:Reason>
<env:Detail>
<sap:Rabax xmlns:sap = "http://www.sap.com/webas/710/soap/runtime/abap/fault/generic">
<SYDATUM>YYYYMMDD</SYDATUM>
<SYUZEIT>HHMMSS</SYUZEIT>
<ERRORCODE>MESSAGE_TYPE_X_TEXT</ERRORCODE>
</sap:Rabax>
</env:Detail>
</env:Fault>
</env:Body>
</env:Envelope>
Cause
While checking the details of the erroneous web service in Web Service Message Monitoring you will notice that a business user was used to execute the web service. However, it is not possible to execute a web service by using a business user.
Resolution
This is expected system behaviour. You must use the technical user, for example _ABCD, maintained in the used Communication Arrangement to execute desired inbound web service interface.
In ByDesign, however, there are some cases (for Supplier Invoices for example) that you are able to do it with a business user.
See Also
Keywords
RABAX occured on server side, An exception was raised, Technical User, Business User, Web Service , KBA , LOD-CRM-OPP , Opportunity Management , How To