Symptom
You replicate data from an external system (e.g. ERP, CRM etc.) and when the message arrives in Cloud for Customer (C4C), you notice that it fails with the following error message:
'Value is no longer than the maximum permitted length X: ABC' (X represents the length of the value and ABC represents the sent value).
Environment
SAP Cloud for Customer
Reproducing the Issue
Pre-requisites: you have a working communication scenario between C4C and an external system.
-
You send e.g. Business Partners from your external system to C4C.
- Open C4C system.
- Go to the Administrator work center.
- Open Web Service Message Monitoring.
- Click on General Settings view.
- Observe the failed message: 'Value is no longer than the maximum permitted length X: ABC'.
Cause
This is expected system behavior.
There are fields in C4C which have a maximum length of characters. Therefore, the value which exceeds this length is not processed by the system, so the message fails.
Resolution
Please, check the problematic value in the payload and make the necessary changes, so the value is accepted in C4C. Alternatively, you can create an extension scenario, where you use an extension field and map the IDOC element to it as well in the middleware.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
maximum permitted length, value longer, web service message monitoring error, C4C, Cloud for Customer, replicate data, ERP, CRM, external system, maximum, length, characters, middleware, behavior. , KBA , LOD-CRM-INT-CRM , Integration of C4C with CRM , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To
SAP Knowledge Base Article - Public