Symptom
Survey A was initially assigned to a Visit via Activity Routing Rules. After updating the rule conditions, Survey B is assigned; however, both Survey A and Survey B are visible in the Visit.
Environment
SAP Cloud for Customer core applications
Reproducing the Issue
- Go to the Visits work center.
- Open Visit XYZ (where XYZ represents the Visit ID).
- Navigate to the Surveys facet.
Result:Both Survey A and Survey B are assigned to the Visit.
Cause
Once a survey is assigned to a Visit, it is not automatically removed, even if the Activity Routing Rules or related conditions are later changed.
Resolution
This is the expected system behavior. Surveys that are no longer required must be removed manually by following the steps below:
- Go to the Activity Planner work center.
- Navigate to the Plans view.
- Open Activity Plan 123 (where 123 is the plan assigned to Visit XYZ).
- Navigate to the Surveys facet.
- Select the survey that is no longer required and click on the Delete icon.
- Click Save.
Keywords
Survey, Visit, Routing Rules, Delete , KBA , LOD-CRM-ACT-VST , Visit Planning , How To
Product
SAP Cloud for Customer core applications 1711
SAP Knowledge Base Article - Public