SAP Knowledge Base Article - Public

2593414 - Wrong Survey Is Assigned to a Visit

Symptom

You have maintained Survey A for a Visit in the Activity Routing Rules initially, and later changed the Activity Routing Rule conditions such that, Survey B is assigned to the Visit.

But observe that both Survey A and Survey B are assigned in the Visit.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to Visits Workcenter
  2. Open the Visit XYZ (Where XYZ represents a Visit ID)
  3. Go to Surveys facet
  4. You observe that Survey A and Survey B both are assigned to this Visit

Cause

Once a Survey is added to a Visit, it will not be automatically removed from that Visit, even if rules and other parameters change.

Resolution

This is an expected system behavior. You have to manually delete the Surveys which are not needed anymore, by following the steps below.

  1. Go to the Activity Planner Workcenter
  2. Navigate to the Plans View
  3. Open the Activity Plan 123 (Where Activity Plan 123 is the plan assigned to the Visit XYZ)
  4. Navigate to the Surveys facet
  5. Select the survey which is not required in the Visit and click on the delete icon
  6. Click on Save

Keywords

survey, visit, wrong survey , KBA , wrong survey , survey , LOD-CRM-ACT-VST , Visit Planning , How To

Product

SAP Cloud for Customer add-ins 1802 ; SAP Cloud for Customer core applications 1711 ; SAP Cloud for Customer core applications 1802 ; SAP Hybris Cloud for Customer add-ins 1711