SAP Knowledge Base Article - Public

2593414 - Incorrect Survey Assigned To a Visit

Symptom

Survey A was initially assigned to a Visit via Activity Routing Rules. After updating the rule conditions, Survey B is assigned; however, both Survey A and Survey B are visible in the Visit.

Environment

SAP Cloud for Customer core applications

Reproducing the Issue

  1. Go to the Visits work center.
  2. Open Visit XYZ (where XYZ represents the Visit ID).
  3. Navigate to the Surveys facet.

    Result:Both Survey A and Survey B are assigned to the Visit. 

Cause

Once a survey is assigned to a Visit, it is not automatically removed, even if the Activity Routing Rules or related conditions are later changed.

Resolution

This is the expected system behavior. Surveys that are no longer required must be removed manually by following the steps below:

  1. Go to the Activity Planner work center.
  2. Navigate to the Plans view.
  3. Open Activity Plan 123 (where 123 is the plan assigned to Visit XYZ).
  4. Navigate to the Surveys facet.
  5. Select the survey that is no longer required and click on the Delete icon.
  6. Click Save.

Keywords

Survey, Visit, Routing Rules, Delete  , KBA , LOD-CRM-ACT-VST , Visit Planning , How To

Product

SAP Cloud for Customer core applications 1711