Symptom
- Accruals did not run automatically for a certain time account type
- When running the simulation accrual run manually you get the following error for all users:
Invalid Booking: null / DAYS / 2018-01-01 / ACCRUAL. Please check rule definition
- In the Time Account Simulation Process tool you see the error
Please assign a value to the following fields: Amount Posted
Environment
- SAP SuccessFactors Employee Central - Time Off
Cause
There is an issue with the Lookup table configuration from the Accrual Rule
Resolution
- Create a rule trace via Business Rule Execution Log or via Manage Data
- Enter Today's date, the rule name, and for the user enter the employee who triggers the calendar run.
- Run the Simulation calendar again to trigger the rule trace
- Download the file from Business Rule Execution Log/Manage Data, and you can see a break down of what is happening for each part of the rule and where the issue occurs (See Also if rule trace result is empty, it's because limitation on 1MB data)
- In this case we can see the result of the lookup table is null
Call function 'lookup', result is 'null'
- This means there is an issue with a value being pulled from the lookup, something does not match
- You should be able to see which values from the lookup were pulled successfully, but if a number/option ID is retrieved instead of the external code/value from the lookup table
- Meaning the lookup tries to find the entry for the number, which is not there
- Check your lookup configuration via Import and export data > Export > Enter the lookup name
See Also
2602486 - Rule trace not capturing logs for all rules
Keywords
SF, success factors, EC, timeoff, didn't run, accruals did not run , KBA , LOD-SF-EC-TIM , Time Off , Problem
Product
SAP SuccessFactors Employee Central all versions